Error in Installing Data.deriveTH

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
I am trying to install this package http://hackage.haskell.org/package/derive. 
ntro@ntro-HP-dx2480-MT-NA121PA:~/Mukesh/assignment_haskell/workl$ cabal install derive
Resolving dependencies...
<command line>: cannot satisfy -package Cabal-1.10.2.0: 
    Cabal-1.10.2.0-072fce39d68f011c6a364057a3d15270 is unusable due to missing or recursive dependencies:
      containers-0.3.0.0-ee442470d8dcc9e45f31677c400c5379
    (use -v for more information)
cabal: Error: some packages failed to install:
derive-2.5.4 depends on haskell-src-exts-1.11.1 which failed to install.
haskell-src-exts-1.11.1 failed during the configure step. The exception was:
ExitFailure 1

ntro@ntro-HP-dx2480-MT-NA121PA:~/Mukesh/assignment_haskell/work$ cabal install haskell-src-exts
Resolving dependencies...
<command line>: cannot satisfy -package Cabal-1.10.2.0: 
    Cabal-1.10.2.0-072fce39d68f011c6a364057a3d15270 is unusable due to missing or recursive dependencies:
      containers-0.3.0.0-ee442470d8dcc9e45f31677c400c5379
    (use -v for more information)
cabal: Error: some packages failed to install:
haskell-src-exts-1.11.1 failed during the configure step. The exception was:
ExitFailure 1

ntro@ntro-HP-dx2480-MT-NA121PA:~/Mukesh/assignment_haskell/work_joel$ cabal install containers
Resolving dependencies...
No packages to be installed. All the requested packages are already installed.
If you want to reinstall anyway then use the --reinstall flag.

Error in Installing Data.deriveTH (annotation)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
ntro@ntro-HP-dx2480-MT-NA121PA:~/Mukesh/assignment_haskell/work_joel$ ghc-pkg list | cat
/var/lib/ghc-6.12.3/package.conf.d:
    Cabal-1.8.0.6
    array-0.3.0.1
    base-3.0.3.2
    base-4.2.0.2
    bin-package-db-0.0.0.0
    bytestring-0.9.1.7
    containers-0.3.0.0
    directory-1.0.1.1
    (dph-base-0.4.0)
    (dph-par-0.4.0)
    (dph-prim-interface-0.4.0)
    (dph-prim-par-0.4.0)
    (dph-prim-seq-0.4.0)
    (dph-seq-0.4.0)
    extensible-exceptions-0.1.1.1
    filepath-1.1.0.4
    (ghc-6.12.3)
    (ghc-binary-0.5.0.2)
    ghc-prim-0.2.0.0
    haskell98-1.0.1.1
    hpc-0.5.0.5
    integer-gmp-0.2.0.1
    old-locale-1.0.0.2
    old-time-1.0.0.5
    pretty-1.0.1.1
    process-1.0.1.3
    random-1.0.0.2
    rts-1.0
    syb-0.1.0.2
    template-haskell-2.4.0.1
    time-1.1.4
    unix-2.4.0.2

/home/ntro/.ghc/i386-linux-6.12.3/package.conf.d:
    Cabal-1.10.2.0
    Crypto-4.2.3
    HTTP-4000.1.1
    HUnit-1.2.4.2
    HaXml-1.22.5
    HaskellNet-0.2.5
    QuickCheck-2.4.1.1
    array-0.3.0.3
    base64-string-0.2
    binary-0.5.0.2
    blaze-builder-0.3.0.1
    cairo-0.12.0
    comonad-1.1.1.1
    comonad-transformers-2.0.2
    comonads-fd-2.0.2
    containers-0.3.0.0
    containers-0.4.1.0
    contravariant-0.1.2.1
    cpphs-1.12
    data-binary-ieee754-0.4.2.1
    data-lens-2.0.1
    dataenc-0.14.0.2
    deepseq-1.1.0.2
    distributive-0.2.0.1
    failure-0.1.0.1
    free-2.0.2
    gio-0.12.0
    glib-0.12.0
    gtk-0.12.0
    hsemail-1.7.1
    keys-2.1.1.1
    mime-mail-0.3.0.3
    mtl-2.0.1.0
    network-2.3.0.2
    pango-0.12.0
    parsec-3.1.1
    polyparse-1.7
    primes-0.2.1.0
    primitive-0.3.1
    regex-base-0.93.2
    regex-compat-0.95.1
    regex-posix-0.95.1
    safe-failure-0.5.0
    semigroupoids-1.2.6
    semigroups-0.8
    tagsoup-0.12.3
    template-haskell-2.4.0.1
    text-0.11.1.5
    transformers-0.2.2.0
    uni-util-2.2.1.1
    uniplate-1.6.2
    utility-ht-0.0.7
    vector-0.7.1
    zlib-0.5.3.1

Error in Installing Data.deriveTH (annotation) (annotation)

1
2
ntro@ntro-HP-dx2480-MT-NA121PA:~/Mukesh/assignment_haskell/work_joel$ ghc-pkg unregister --user array
ghc-pkg: unregistering array would break the following packages: containers-0.4.1.0 uniplate-1.6.2 template-haskell-2.4.0.1 data-binary-ieee754-0.4.2.1 binary-0.5.0.2 uni-util-2.2.1.1 keys-2.1.1.1 free-2.0.2 data-lens-2.0.1 comonads-fd-2.0.2 comonad-transformers-2.0.2 semigroupoids-1.2.6 comonad-1.1.1.1 semigroups-0.8 containers-0.3.0.0 (use --force to override)

Error in Installing Data.deriveTH (annotation) (annotation) (annotation)

1
2
3
4
5
ntro@ntro-HP-dx2480-MT-NA121PA:~/Mukesh/assignment_haskell/work_joel$ ghc-pkg unregister --user containers-0.4.1.0
ghc-pkg: unregistering containers-0.4.1.0 would break the following packages: uniplate-1.6.2 (use --force to override)

ntro@ntro-HP-dx2480-MT-NA121PA:~/Mukesh/assignment_haskell/work_joel$ ghc-pkg unregister --user containers-0.3.0.0
ghc-pkg: unregistering containers-0.3.0.0 would break the following packages: data-binary-ieee754-0.4.2.1 binary-0.5.0.2 uni-util-2.2.1.1 keys-2.1.1.1 free-2.0.2 data-lens-2.0.1 comonads-fd-2.0.2 comonad-transformers-2.0.2 semigroupoids-1.2.6 comonad-1.1.1.1 semigroups-0.8 (use --force to override)

Error in Installing Data.deriveTH (annotation) (annotation) (annotation) (annotation)

1
http://www.vex.net/~trebla/haskell/sicp.xhtml

Error in Installing Data.deriveTH (annotation) (annotation) (annotation) (annotation) (annotation)

1
2
3
http://www.vex.net/~trebla/haskell/sicp.xhtml
wipe ~/.ghc
cabal install pkg-name --dry-run to test which package its going to install.