Fedora 17 wx erros

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
cabal install wxc
Resolving dependencies...
[1 of 1] Compiling Main             ( /tmp/wxc-0.90.0.42509/wxc-0.90.0.4/Setup.hs, /tmp/wxc-0.90.0.42509/wxc-0.90.0.4/dist/setup/Main.o )
Linking /tmp/wxc-0.90.0.42509/wxc-0.90.0.4/dist/setup/setup ...
Configuring wxc-0.90.0.4...
setup: failed
cabal: Error: some packages failed to install:
wxc-0.90.0.4 failed during the configure step. The exception was:
ExitFailure 1

{- i thought to use -v so below is that -}

cabal install wxc -v
Reading available packages...
Resolving dependencies...
In order, the following would be installed:
wxc-0.90.0.4 (new package)
Extracting
/home/n/.cabal/packages/hackage.haskell.org/wxc/0.90.0.4/wxc-0.90.0.4.tar.gz
to /tmp/wxc-0.90.0.43570...
creating /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup
creating /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist
creating /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup
/usr/bin/ghc --make /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/Setup.hs -o /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup/setup -odir /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup -hidir /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup -i -i/tmp/wxc-0.90.0.43570/wxc-0.90.0.4 -package Cabal-1.10.2.0
[1 of 1] Compiling Main             ( /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/Setup.hs, /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup/Main.o )
Linking /tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup/setup ...
/tmp/wxc-0.90.0.43570/wxc-0.90.0.4/dist/setup/setup configure --verbose=2
--ghc --prefix=/home/n/.cabal --user --constraint=base ==4.3.1.0
--constraint=wxdirect ==0.90.0.1
Configuring wxc-0.90.0.4...
Dependency base ==4.3.1.0: using base-4.3.1.0
Dependency wxdirect ==0.90.0.1: using wxdirect-0.90.0.1
Using Cabal-1.10.2.0 compiled by ghc-7.0
Using compiler: ghc-7.0.4
Using install prefix: /home/n/.cabal
Binaries installed in: /home/n/.cabal/bin
Libraries installed in: /home/n/.cabal/lib/wxc-0.90.0.4/ghc-7.0.4
Private binaries installed in: /home/n/.cabal/libexec
Data files installed in: /home/n/.cabal/share/wxc-0.90.0.4
Documentation installed in: /home/n/.cabal/share/doc/wxc-0.90.0.4
Using alex version 2.3.5 found on system at: /usr/bin/alex
Using ar found on system at: /usr/bin/ar
No c2hs found
No cpphs found
No ffihugs found
Using gcc version 4.7.0 found on system at: /usr/bin/gcc
Using ghc version 7.0.4 found on system at: /usr/bin/ghc
Using ghc-pkg version 7.0.4 found on system at: /usr/bin/ghc-pkg
No greencard found
Using haddock version 2.9.2 found on system at: /usr/bin/haddock
Using happy version 1.18.6 found on system at: /usr/bin/happy
No hmake found
Using hsc2hs version 0.67 found on system at: /usr/bin/hsc2hs
Using hscolour version 1.19 found on system at: /usr/bin/HsColour
No hugs found
No jhc found
Using ld found on system at: /usr/bin/ld
No lhc found
No lhc-pkg found
No nhc98 found
Using pkg-config version 0.25 found on system at: /usr/bin/pkg-config
Using ranlib found on system at: /usr/bin/ranlib
Using strip found on system at: /usr/bin/strip
Using tar found on system at: /usr/bin/tar
No uhc found
setup: failed
World file is already up to date.
cabal: Error: some packages failed to install:
wxc-0.90.0.4 failed during the configure step. The exception was:
ExitFailure 1

{- i then tried to install say lhc which failed -_- -}

cabal install lhc -v
Reading available packages...
Resolving dependencies...
In order, the following would be installed:
lhc-0.10 (new package)
Extracting
/home/n/.cabal/packages/hackage.haskell.org/lhc/0.10/lhc-0.10.tar.gz to
/tmp/lhc-0.103644...
creating /tmp/lhc-0.103644/lhc-0.10/dist/setup
creating /tmp/lhc-0.103644/lhc-0.10/dist
creating /tmp/lhc-0.103644/lhc-0.10/dist/setup
/usr/bin/ghc --make /tmp/lhc-0.103644/lhc-0.10/Setup.hs -o /tmp/lhc-0.103644/lhc-0.10/dist/setup/setup -odir /tmp/lhc-0.103644/lhc-0.10/dist/setup -hidir /tmp/lhc-0.103644/lhc-0.10/dist/setup -i -i/tmp/lhc-0.103644/lhc-0.10 -package Cabal-1.10.2.0
[1 of 1] Compiling Main             ( /tmp/lhc-0.103644/lhc-0.10/Setup.hs, /tmp/lhc-0.103644/lhc-0.10/dist/setup/Main.o )
Linking /tmp/lhc-0.103644/lhc-0.10/dist/setup/setup ...
/tmp/lhc-0.103644/lhc-0.10/dist/setup/setup configure --verbose=2 --ghc
--prefix=/home/n/.cabal --user --flags=-with-libs --flags=lhc-pkg
--flags=-lhc-regress --flags=-threaded --flags=-hpc --constraint=Cabal
==1.10.2.0 --constraint=HUnit ==1.2.4.2 --constraint=QuickCheck ==1.2.0.1
--constraint=ansi-wl-pprint ==0.6.4 --constraint=base ==4.3.1.0
--constraint=binary ==0.5.0.2 --constraint=bytestring ==0.9.1.10
--constraint=bytestring-trie ==0.2.3 --constraint=containers ==0.4.0.0
--constraint=core ==0.5 --constraint=derive ==2.5.9 --constraint=digest
==0.0.1.0 --constraint=directory ==1.1.0.0 --constraint=extensible-exceptions
==0.1.1.2 --constraint=filepath ==1.2.0.0 --constraint=haskell98 ==1.1.0.1
--constraint=mtl ==2.0.1.0 --constraint=parallel ==3.1.0.1 --constraint=pretty
==1.0.1.2 --constraint=process ==1.0.1.5 --constraint=test-framework ==0.6
--constraint=test-framework-hunit ==0.2.7
--constraint=test-framework-quickcheck ==0.2.8.1 --constraint=time ==1.2.0.3
--constraint=unix ==2.4.2.0 --constraint=xhtml ==3000.2.0.4
Configuring lhc-0.10...
Flags chosen: with-libs=False, lhc-pkg=True, lhc-regress=False,
threaded=False, hpc=False
Dependency Cabal ==1.10.2.0: using Cabal-1.10.2.0
Dependency HUnit ==1.2.4.2: using HUnit-1.2.4.2
Dependency QuickCheck ==1.2.0.1: using QuickCheck-1.2.0.1
Dependency ansi-wl-pprint ==0.6.4: using ansi-wl-pprint-0.6.4
Dependency base ==4.3.1.0: using base-4.3.1.0
Dependency binary ==0.5.0.2: using binary-0.5.0.2
Dependency bytestring ==0.9.1.10: using bytestring-0.9.1.10
Dependency bytestring-trie ==0.2.3: using bytestring-trie-0.2.3
Dependency containers ==0.4.0.0: using containers-0.4.0.0
Dependency core ==0.5: using core-0.5
Dependency derive ==2.5.9: using derive-2.5.9
Dependency digest ==0.0.1.0: using digest-0.0.1.0
Dependency directory ==1.1.0.0: using directory-1.1.0.0
Dependency extensible-exceptions ==0.1.1.2: using
extensible-exceptions-0.1.1.2
Dependency filepath ==1.2.0.0: using filepath-1.2.0.0
Dependency haskell98 ==1.1.0.1: using haskell98-1.1.0.1
Dependency mtl ==2.0.1.0: using mtl-2.0.1.0
Dependency parallel ==3.1.0.1: using parallel-3.1.0.1
Dependency pretty ==1.0.1.2: using pretty-1.0.1.2
Dependency process ==1.0.1.5: using process-1.0.1.5
Dependency test-framework ==0.6: using test-framework-0.6
Dependency test-framework-hunit ==0.2.7: using test-framework-hunit-0.2.7
Dependency test-framework-quickcheck ==0.2.8.1: using
test-framework-quickcheck-0.2.8.1
Dependency time ==1.2.0.3: using time-1.2.0.3
Dependency unix ==2.4.2.0: using unix-2.4.2.0
Dependency xhtml ==3000.2.0.4: using xhtml-3000.2.0.4
Using Cabal-1.10.2.0 compiled by ghc-7.0
Using compiler: ghc-7.0.4
Using install prefix: /home/n/.cabal
Binaries installed in: /home/n/.cabal/bin
Libraries installed in: /home/n/.cabal/lib/lhc-0.10/ghc-7.0.4
Private binaries installed in: /home/n/.cabal/libexec
Data files installed in: /home/n/.cabal/share/lhc-0.10
Documentation installed in: /home/n/.cabal/share/doc/lhc-0.10
Using alex version 2.3.5 found on system at: /usr/bin/alex
Using ar found on system at: /usr/bin/ar
No c2hs found
No cpphs found
No ffihugs found
Using gcc version 4.7.0 found on system at: /usr/bin/gcc
Using ghc version 7.0.4 found on system at: /usr/bin/ghc
Using ghc-pkg version 7.0.4 found on system at: /usr/bin/ghc-pkg
No greencard found
Using haddock version 2.9.2 found on system at: /usr/bin/haddock
Using happy version 1.18.6 found on system at: /usr/bin/happy
No hmake found
Using hsc2hs version 0.67 found on system at: /usr/bin/hsc2hs
Using hscolour version 1.19 found on system at: /usr/bin/HsColour
No hugs found
No jhc found
Using ld found on system at: /usr/bin/ld
No lhc found
No lhc-pkg found
No nhc98 found
Using pkg-config version 0.25 found on system at: /usr/bin/pkg-config
Using ranlib found on system at: /usr/bin/ranlib
Using strip found on system at: /usr/bin/strip
Using tar found on system at: /usr/bin/tar
No uhc found
creating /tmp/lhc-0.103644/lhc-0.10/dist/setup
/tmp/lhc-0.103644/lhc-0.10/dist/setup/setup build --verbose=2
setup: Package lhc-0.10 can't be built on this system.
World file is already up to date.
cabal: Error: some packages failed to install:
lhc-0.10 failed during the building phase. The exception was:
ExitFailure 1