buildwrapper

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
Resolving dependencies...
Configuring buildwrapper-0.7.4...
Building buildwrapper-0.7.4...
Preprocessing library buildwrapper-0.7.4...
[1 of 7] Compiling Language.Haskell.BuildWrapper.Base ( src\Language\Haskell\Bui
ldWrapper\Base.hs, dist\build\Language\Haskell\BuildWrapper\Base.o )
[2 of 7] Compiling Language.Haskell.BuildWrapper.GHCStorage ( src\Language\Haske
ll\BuildWrapper\GHCStorage.hs, dist\build\Language\Haskell\BuildWrapper\GHCStora
ge.o )
[3 of 7] Compiling Language.Haskell.BuildWrapper.Src ( src\Language\Haskell\Buil
dWrapper\Src.hs, dist\build\Language\Haskell\BuildWrapper\Src.o )

src\Language\Haskell\BuildWrapper\Src.hs:41:59:
    Couldn't match type `Extension' with `KnownExtension'
    Expected type: [KnownExtension]
      Actual type: [Extension]
    In the second argument of `(:)', namely
      `(map
          (\ x
             -> classifyExtension
                $ if "-X" `isPrefixOf` x then tail $ tail x else x)
        $ options ++ optionsFromPragmas)'
    In the second argument of `(:)', namely
      `PatternGuards
       : (map
            (\ x
               -> classifyExtension
                  $ if "-X" `isPrefixOf` x then tail $ tail x else x)
          $ options ++ optionsFromPragmas)'
    In the expression:
      MultiParamTypeClasses
      : PatternGuards
        : (map
             (\ x
                -> classifyExtension
                   $ if "-X" `isPrefixOf` x then tail $ tail x else x)
           $ options ++ optionsFromPragmas)
Failed to install buildwrapper-0.7.4
cabal: Error: some packages failed to install:
buildwrapper-0.7.4 failed during the building phase. The exception was:
ExitFailure 1