cabal new-build resolution error

Anonymous Coward 2018-03-07 19:18:25.467081 UTC

1$ cabal-head new-configure myproject 1
2Resolving dependencies...
3cabal-head: Could not resolve dependencies:
4[__0] trying: common-utilities-1.17.0 (user goal)
5[__1] next goal: monad-logger (dependency of common-utilities)
6[__1] rejecting: monad-logger-0.3.28.1, monad-logger-0.3.28 (constraint from
7project config TODO requires ==0.3.26)
8[__1] trying: monad-logger-0.3.26
9[__2] trying: stm-chans-3.0.0.4 (dependency of monad-logger)
10[__3] next goal: stm-chans:setup.Cabal (dependency of stm-chans)
11[__3] rejecting: stm-chans:setup.Cabal-2.0.1.0/installed-2.0...,
12stm-chans:setup.Cabal-2.0.1.1, stm-chans:setup.Cabal-2.0.1.0,
13stm-chans:setup.Cabal-2.0.0.2 (conflict: stm-chans =>
14stm-chans:setup.Cabal>=1.6 && <1.25)
15[__3] rejecting: stm-chans:setup.Cabal-1.24.2.0,
16stm-chans:setup.Cabal-1.24.0.0, stm-chans:setup.Cabal-1.22.8.0,
17stm-chans:setup.Cabal-1.22.7.0, stm-chans:setup.Cabal-1.22.6.0,
18stm-chans:setup.Cabal-1.22.5.0, stm-chans:setup.Cabal-1.22.4.0,
19stm-chans:setup.Cabal-1.22.3.0, stm-chans:setup.Cabal-1.22.2.0,
20stm-chans:setup.Cabal-1.22.1.1, stm-chans:setup.Cabal-1.22.1.0,
21stm-chans:setup.Cabal-1.22.0.0, stm-chans:setup.Cabal-1.20.0.4,
22stm-chans:setup.Cabal-1.20.0.3, stm-chans:setup.Cabal-1.20.0.2,
23stm-chans:setup.Cabal-1.20.0.1, stm-chans:setup.Cabal-1.20.0.0,
24stm-chans:setup.Cabal-1.18.1.7, stm-chans:setup.Cabal-1.18.1.6,
25stm-chans:setup.Cabal-1.18.1.5, stm-chans:setup.Cabal-1.18.1.4,
26stm-chans:setup.Cabal-1.18.1.3, stm-chans:setup.Cabal-1.18.1.2,
27stm-chans:setup.Cabal-1.18.1.1, stm-chans:setup.Cabal-1.18.1,
28stm-chans:setup.Cabal-1.18.0, stm-chans:setup.Cabal-1.16.0.3,
29stm-chans:setup.Cabal-1.16.0.2, stm-chans:setup.Cabal-1.16.0.1,
30stm-chans:setup.Cabal-1.16.0, stm-chans:setup.Cabal-1.14.0,
31stm-chans:setup.Cabal-1.12.0, stm-chans:setup.Cabal-1.10.2.0,
32stm-chans:setup.Cabal-1.10.1.0, stm-chans:setup.Cabal-1.10.0.0,
33stm-chans:setup.Cabal-1.8.0.6, stm-chans:setup.Cabal-1.8.0.4,
34stm-chans:setup.Cabal-1.8.0.2, stm-chans:setup.Cabal-1.6.0.3,
35stm-chans:setup.Cabal-1.6.0.2, stm-chans:setup.Cabal-1.6.0.1,
36stm-chans:setup.Cabal-1.4.0.2, stm-chans:setup.Cabal-1.4.0.1,
37stm-chans:setup.Cabal-1.4.0.0, stm-chans:setup.Cabal-1.2.4.0,
38stm-chans:setup.Cabal-1.2.3.0, stm-chans:setup.Cabal-1.2.2.0,
39stm-chans:setup.Cabal-1.2.1, stm-chans:setup.Cabal-1.1.6,
40stm-chans:setup.Cabal-1.24.1.0 (constraint from minimum version of Cabal used
41by Setup.hs requires >=2.0)
42After searching the rest of the dependency tree exhaustively, these were the
43goals I've had most trouble fulfilling: stm-chans:setup.Cabal, monad-logger,
44stm-chans, common-utilities